Author Topic: B.T. 1.75  (Read 75 times)

0 Members and 1 Guest are viewing this topic.

Offline BeemerBiker

  • Jr. Member
  • **
  • Posts: 52
    • View Profile
    • ResearchRiders
B.T. 1.75
« on: January 30, 2018, 01:45:36 am »
[EDIT] - HMM--cannot do an attachment.  Dont see any way under Chrome.  I will put on my website
http://stateson.net/rules.zip maybe someone can tell me how to add a zip file attachment.

I need to implement a rule and I first tried 1.73 then the beta.  I was successful in implementing two somewhat similar rules, but there was a problem (bug) that I would like to report and also a feature request.

Some history:  Occasionally, one or another of my systems gets an nVidia or ATI kernel error and recovers usually immediately with no bad effects.  Unfortunately, one of my video board, an HD7950 occasionally does not recover.  I discovered that simply suspending and resuming any project on that board will fix the problem.  A sleep command for 10 seconds works fine and is easy to implement at the win10x64 command prompt with "boinccmd --set_gpu_mode never 10".  I thought I would implement a rule to do this for me.  This board processes MilkyWay tasks that take no more than 3 minutes.  At 5 minutes elapsed time there must be a real problem so I based my rule on MilkyWay.  I installed boinctasks on that system, made sure that history was enabled and configured and tested the rule which worked (after some time tinkering of course).  Attached to this post is a zip that contains the rule, and two command files.  One FixGPU.bat causes boinc to sleep, the other, CallMe.vbs sends me a text message about the problem and is called by FixGPU.

All seemed to be fine until I decided I wanted to do this from my main desktop system and not have boinctasks run on the dedicated boinc research system.  I ran to two problems.

1.  Feature request:  It is not possible to run a local program and also issue a sleep command to a remote system.  The bottom right corner box is where the sleep parameter goes.  That is the same box that is supposed to have the path to the program that I wanted to run so as to send a text message to my cell.

2.  Both 1.73 and 1.75 improperly handle the sleep parameter.  Where the rules.xml file has <ivalue0>300</ivalue0> that puts "00d,00:05:00" into the dialog box "value" which is correct.  I used 5 seconds for the time for the 5 minute MilkyWay threshold and I put 10 into the bottom right corner box.  Unaccountably, when clicking on "check" the 5 minutes is changed to 10 seconds.  One or more of the fields in the dialog box are accessed improperly.  After "OK" and exiting, if one does a file compare of the rules.xml with a backup you can spot that the 300 seconds was changed to 10 seconds which is incorrect.  I have tested my rules.xml file and it works but you must edit it to put in "yes" to activated it because if you ever bring it up in the rules editor dialog box it will get corrupted.  I am including two pictures that demonstrate the problem.

Here is my working rules.xml file
    <rules>
    <rule>
        <active>yes</active>
        <name>7950</name>
        <computer>z400-3-RX570</computer>
        <project>Milkyway@Home</project>
        <appliation>1.46%20MilkyWay@Home%20(opencl_ati_101)</appliation>
        <type0>5</type0>
        <type1>0</type1>
        <type2>0</type2>
        <operator0>2</operator0>
        <operator1>0</operator1>
        <operator2>0</operator2>
        <ivalue0>300</ivalue0>
        <ivalue1>-1</ivalue1>
        <ivalue2>-1</ivalue2>
        <dvalue0>0.000000</dvalue0>
        <dvalue1>-1.000000</dvalue1>
        <dvalue2>-1.000000</dvalue2>
        <itime>5</itime>
        <color>6569215</color>
        <event_show>1</event_show>
        <event_internal>7</event_internal>
        <event_external>0</event_external>
        <event_parameters>10</event_parameters>
    </rule>
    </rules>

This is what happens if it is brought up in the rules dialog box.  The file compare is under it.  Note that the 5 minutes was changed to 10 seconds.




« Last Edit: January 30, 2018, 07:24:03 am by BeemerBiker »

Offline fred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3263
  • eFMer
    • View Profile
    • Trails
Re: B.T. 1.75
« Reply #1 on: January 30, 2018, 08:46:47 pm »
I will put it on my to do list. Right now I'm doing something else.
In a couple of months I will take a look at this problem.

Offline Jimbocous

  • Jr. Member
  • **
  • Posts: 5
    • View Profile
Re: B.T. 1.75
« Reply #2 on: February 12, 2018, 01:52:30 am »
Just loaded 1.75, and decided to test the new ability of editing app_config.xml.
Setup here is as follows:
1) Core2 Q9650, Win10ProX64, BT 1.75, BOINC 7.8.3, Projects: SETI, Einstein
2) Xeon E5450, Win7ProX64,                   BOINC 7.8.3, Projects: SETI, Einstein
3) Xeon X5675, Win10ProX64,                 BOINC 7.8.3, Projects: SETI, SETI Beta, Einstein
4) Xeon X5675, Win10ProX64,                 BOINC 7.8.3, Projects: SETI, SETI Beta, Einstein
Installation file paths are standard for BOINC and BT on all machines.

From machine 1) under Projects tab was able to load and read app_config for Einstein and SETI Beta on all machines (SETI uses app_info on all).
However, after making a change to Einstein on all 4 machines and to Beta on the two machines running it:
 Syntax Check passes,
 Apply passes,
 A subsequent attempt to load app_config yields an "Invalid" window message in each case.

Further checking shows that each app_config is now file size 0 and all data has been lost.

Stupid me, of course, for not having made backups before testing a new feature, and for not having validated everything on 1 machine before moving on to the other three.
But I thought I would mention this for anyone else testing, to see if there's something else I did to screw this up or info I can provide to help find a resolution.
If I might also suggest, perhaps it would be good to have BT make a .BAK backup file of app/cc_config XML files before making changes to them, if that is possible.
Feel free to let me know how I might help! Thanks!

[edit]
Also, it seems app_config editor is failing syntax check on <gpu_versions> statement. 
« Last Edit: February 12, 2018, 03:19:05 am by Jimbocous »

Offline Jimbocous

  • Jr. Member
  • **
  • Posts: 5
    • View Profile
Re: B.T. 1.75
« Reply #3 on: February 12, 2018, 02:07:13 am »
Hey BeemerBiker.
Maybe I'm totally off-base here, but shouldn't
<appliation>1.46%20MilkyWay@Home%20(opencl_ati_101)</appliation>
be
<application>1.46%20MilkyWay@Home%20(opencl_ati_101)</application>

Don't know anything about this, but it just looked wrong :-\
Jim ...
« Last Edit: February 12, 2018, 02:17:11 am by Jimbocous »