Author Topic: Can't connect to BOINC client  (Read 43 times)

0 Members and 1 Guest are viewing this topic.

Offline Shin

  • Newbie
  • *
  • Posts: 2
    • View Profile
Can't connect to BOINC client
« on: March 19, 2020, 11:50:26 am »
I can't seem to find or add my computer running BOINC using the "Find computer" or "Add computer" menus. I used the machine IP, password in gui_rpc_auth.cfg, and port 31416. But no luck, I've tried adding a TCP exception in the firewall but that doesn't seem to work either.

Any idea around this? Not sure if it's just me forgetting something.  ::)

Offline JStateson

  • Jr. Member
  • **
  • Posts: 74
  • Retired, SwRI, Principal Analyst
    • View Profile
    • ResearchRiders
Re: Can't connect to BOINC client
« Reply #1 on: March 19, 2020, 01:37:50 pm »
Windows or Linux client?

If Linux then at /etc/boinc-client you need to edit the file remote_hosts.cfg and add the name of the boinctasks system or its IP address.  This is not needed for windows.

If client is in windows make sure there is only one client running and that the manager is not running.  Use tasks manager to verify.  Make sure that each system can "ping" the other using system names else network problem.

From the system running the client, from an admin command prompt do the following:
c:\Program Files\boinc>boinccmd --get_host_info

do the same thing from system running boinctasks. I assume it is also running boinc (but not boincmgr)
c:\Program Files\boinc>boinccmd --host YOUR_REMOTE_SYSTEM --get_host_info

Installing boinctasks under windows should automatically ask to allow access through the firewall.

If each system can ping each other then try a telnet connection from the boinctasks system to the client

telnet YOUR_REMOTE_SYSTEM 31416

Pressing CTRL-C should generate an error message such as "<boinc_gui_rpc_reply>" plus other stuff.   If you do not see that message suspect firewall or network problem.  Use CTRL-] then "quit" to exit telnet.

HTH
« Last Edit: March 19, 2020, 01:49:02 pm by JStateson »

Offline Shin

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Can't connect to BOINC client
« Reply #2 on: March 19, 2020, 02:56:51 pm »
I tried the host-info command and got the IP, but even that doesn't work when trying to connect. When I do the host-info to a remote machine that doesn't output anything.
I can ping both IPs perfectly with instant responses. Both machines are Windows

And I have checked that only one BOINC client is running.

Offline JStateson

  • Jr. Member
  • **
  • Posts: 74
  • Retired, SwRI, Principal Analyst
    • View Profile
    • ResearchRiders
Re: Can't connect to BOINC client
« Reply #3 on: March 21, 2020, 04:24:06 am »
Put the following into the cc_config.xml file at \programdata\boinc under "options"

<allow_remote_gui_rpc>1</allow_remote_gui_rpc>

suggest this:
<cc_config>
  <log_flags>
  </log_flags>
  <options>
   <use_all_gpus>1</use_all_gpus>
   <allow_remote_gui_rpc>1</allow_remote_gui_rpc>
  </options>
</cc_config>

double check your password file for white space or unprintable character.   If you delete the gui_rpc_auth.cfg file it is automatically re-created with a 32 char password when boinc starts up.  Best is to use notepad and delete the line and save an empty file.  Its length should be exactly "0" unless you want a password
« Last Edit: March 21, 2020, 04:27:50 am by JStateson »