Author Topic: Version numbers  (Read 2272 times)

0 Members and 1 Guest are viewing this topic.

Offline Corsair

  • Tester
  • Hero Member
  • *****
  • Posts: 539
    • View Profile
Version numbers
« on: June 09, 2009, 10:32:15 am »
Hi all,

in previous versions I had a fix with the updater, on the way that 1.59 beta or 1.60 beta
were installed and I clicked the mouse in the icon and update, look for new version, and
I got, new version found 1.58 ???

why not numbering the beta versions as e.g. 1.61.0...X and the definitive version as the
last number of the list while in the same version, in order not to have this tricky upgrade
(dowgrade if followed).

in that way some minor released could be done for cosmetic bugs, etc.

e.g. if the definitive version is 1.61.4 but there is a small correction before a newer version
could be 1.61.5 and up without making Fred crazy with all the stuff we ask.

Cheers  ;)
over the sailors' grave doesn't grove grass.

Corsair.

Offline fred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3431
  • eFMer
    • View Profile
    • Trails
Re: Version numbers
« Reply #1 on: June 09, 2009, 11:13:26 am »
Hi all,

in previous versions I had a fix with the updater, on the way that 1.59 beta or 1.60 beta
were installed and I clicked the mouse in the icon and update, look for new version, and
I got, new version found 1.58 ???

why not numbering the beta versions as e.g. 1.61.0...X and the definitive version as the
last number of the list while in the same version, in order not to have this tricky upgrade
(dowgrade if followed).

in that way some minor released could be done for cosmetic bugs, etc.

e.g. if the definitive version is 1.61.4 but there is a small correction before a newer version
could be 1.61.5 and up without making Fred crazy with all the stuff we ask.

Cheers  ;)
Yes that is something. Keep the last number for beta only. So it is a good thing we have 1.60 now as a release.
1.61, 1.62 for beta an 1.70 for release.
A downgrade will not work (I hope) because the installer doesn't install older programs over newer. So that should not be a problem.
But I will change the update so that you don't get messages about older versions.