Author Topic: Mixed NVidia and ATI GPUs  (Read 10544 times)

0 Members and 1 Guest are viewing this topic.

Offline fred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3431
  • eFMer
    • View Profile
    • Trails
Re: Mixed NVidia and ATI GPUs
« Reply #15 on: August 26, 2010, 05:42:25 am »
25 August 2010 - 17:15:46 Rishi, SendRecieve ---- Recieved from Server:
<TThrottle><HN:Rishi><PV 2.10><AC 1><TC 39><TG 62><NV 1><NA 1><DC 100><DG 100><CT0 39.0><GT0 61.7><GT1 57.0><GT4 0.0><GT5 0.0>

Looks like GT0 is the NVidia and GT1 the ATI on this system. 
And by <NV 1> and <NA 1> it looks like it's correctly passing the GPU identities.
But on BT both GPU temps report as 61.7.
Looks fine on the TThrottle side.
Go to Menu: Extra -> BoincTasks settings -> Tasks and remove the check at "Condense Use column"
What's in the Use column of the NVIDIA and ATA card. A screenshot maybe, because the text has to be pretty exact?
Another way may be to copy the lines from the history.



Offline Beyond

  • Active Member
  • Full Member
  • *****
  • Posts: 242
    • View Profile
Re: Mixed NVidia and ATI GPUs
« Reply #16 on: August 26, 2010, 10:46:53 am »
25 August 2010 - 17:15:46 Rishi, SendRecieve ---- Recieved from Server:
<TThrottle><HN:Rishi><PV 2.10><AC 1><TC 39><TG 62><NV 1><NA 1><DC 100><DG 100><CT0 39.0><GT0 61.7><GT1 57.0><GT4 0.0><GT5 0.0>

Looks like GT0 is the NVidia and GT1 the ATI on this system. 
And by <NV 1> and <NA 1> it looks like it's correctly passing the GPU identities.
But on BT both GPU temps report as 61.7.
Looks fine on the TThrottle side.
Go to Menu: Extra -> BoincTasks settings -> Tasks and remove the check at "Condense Use column"
What's in the Use column of the NVIDIA and ATA card. A screenshot maybe, because the text has to be pretty exact?
Another way may be to copy the lines from the history.

0.01 CPUs + 1.00 NVIDIA GPUs
0.02 CPUs + 1.00 ATI GPUs

There's no (device 0) or (device 1) on these.

Offline Beyond

  • Active Member
  • Full Member
  • *****
  • Posts: 242
    • View Profile
Re: Mixed NVidia and ATI GPUs
« Reply #17 on: August 26, 2010, 10:50:58 am »

Another way may be to copy the lines from the history.

Rishi   Collatz Conjecture   2.04 collatz (cuda)   collatz_1282112751_506256_0   00:09:52 (00:00:45)   8/26/2010 5:41:02 AM   8/26/2010 5:44:58 AM   0.01 CPUs + 1.00 NVIDIA GPUs   Reported: OK
Rishi   Collatz Conjecture   2.09 collatz (ati13ati)   collatz_1282112751_506737_0   00:10:40 (00:10:39)   8/26/2010 5:40:07 AM   8/26/2010 5:44:58 AM   0.02 CPUs + 1.00 ATI GPUs   Reported: OK


Offline fred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3431
  • eFMer
    • View Profile
    • Trails
Re: Mixed NVidia and ATI GPUs
« Reply #18 on: August 26, 2010, 01:01:11 pm »

Another way may be to copy the lines from the history.

Rishi   Collatz Conjecture   2.04 collatz (cuda)   collatz_1282112751_506256_0   00:09:52 (00:00:45)   8/26/2010 5:41:02 AM   8/26/2010 5:44:58 AM   0.01 CPUs + 1.00 NVIDIA GPUs   Reported: OK
Rishi   Collatz Conjecture   2.09 collatz (ati13ati)   collatz_1282112751_506737_0   00:10:40 (00:10:39)   8/26/2010 5:40:07 AM   8/26/2010 5:44:58 AM   0.02 CPUs + 1.00 ATI GPUs   Reported: OK


Puzzling, everything checks out ok.
Something else to check, it uses the same detector to see if the GPU is ATI.

Enable the debt column and see if you got the right debt for the ATI and the NVIDIA.
The debt should be the same as in the Project tab, select the same project and with the right mouse key select properties.

Offline Beyond

  • Active Member
  • Full Member
  • *****
  • Posts: 242
    • View Profile
Re: Mixed NVidia and ATI GPUs
« Reply #19 on: August 26, 2010, 03:46:37 pm »

Puzzling, everything checks out ok.
Something else to check, it uses the same detector to see if the GPU is ATI.

Enable the debt column and see if you got the right debt for the ATI and the NVIDIA.
The debt should be the same as in the Project tab, select the same project and with the right mouse key select properties.

The debts are 0 as Collatz is the only GPU project running on that machine.  The debts are also 0 for the GPU projects on my other machines that have MW set to project priority 333 and Collatz set to project priority 0.  Checkpoints do seem to be showing separately and correctly on the mixed GPU machine running Collatz.  Progress %, Elapsed Time and Time Left are all correct.  Only the ATI temp is incorrect.

Offline fred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3431
  • eFMer
    • View Profile
    • Trails
Re: Mixed NVidia and ATI GPUs
« Reply #20 on: August 26, 2010, 03:53:28 pm »
The debts are 0 as Collatz is the only GPU project running on that machine.  The debts are also 0 for the GPU projects on my other machines that have MW set to project priority 333 and Collatz set to project priority 0.  Checkpoints do seem to be showing separately and correctly on the mixed GPU machine running Collatz.  Progress %, Elapsed Time and Time Left are all correct.  Only the ATI temp is incorrect.
I will build in some debug info in the next version, to check what is going on.

Offline fred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3431
  • eFMer
    • View Profile
    • Trails
Re: Mixed NVidia and ATI GPUs
« Reply #21 on: September 12, 2010, 12:21:58 pm »
The debts are 0 as Collatz is the only GPU project running on that machine.  The debts are also 0 for the GPU projects on my other machines that have MW set to project priority 333 and Collatz set to project priority 0.  Checkpoints do seem to be showing separately and correctly on the mixed GPU machine running Collatz.  Progress %, Elapsed Time and Time Left are all correct.  Only the ATI temp is incorrect.
I will build in some debug info in the next version, to check what is going on.
Use version 0.73:

Change the following file: C:\Program Files\eFMer\BoincTasks\log\log.xml
Set the ONLY the following to 1:
      <tthrottle_read>      1   </tthrottle_read>
      <temperature_gpu>   1   </temperature_gpu>

Select only the mixed NVIDIA / ATI computer in computers.
Exit BoincTasks and restart it.
Menu: Show->Log and check "debug"

Let it run a couple of seconds to get about 3 readings.

Remove the debug check and send me the log, lets see if that tells me something useful.

Offline Beyond

  • Active Member
  • Full Member
  • *****
  • Posts: 242
    • View Profile
Re: Mixed NVidia and ATI GPUs
« Reply #22 on: October 02, 2010, 06:04:17 pm »
The debts are 0 as Collatz is the only GPU project running on that machine.  The debts are also 0 for the GPU projects on my other machines that have MW set to project priority 333 and Collatz set to project priority 0.  Checkpoints do seem to be showing separately and correctly on the mixed GPU machine running Collatz.  Progress %, Elapsed Time and Time Left are all correct.  Only the ATI temp is incorrect.
I will build in some debug info in the next version, to check what is going on.
Use version 0.73:

Change the following file: C:\Program Files\eFMer\BoincTasks\log\log.xml
Set the ONLY the following to 1:
      <tthrottle_read>      1   </tthrottle_read>
      <temperature_gpu>   1   </temperature_gpu>

Select only the mixed NVIDIA / ATI computer in computers.
Exit BoincTasks and restart it.
Menu: Show->Log and check "debug"

Let it run a couple of seconds to get about 3 readings.

Remove the debug check and send me the log, lets see if that tells me something useful.

Sorry this took so long.  Used v0.73:

02 October 2010 - 12:40:49 Logging ---- Start debug mode
02 October 2010 - 12:40:49 Logging ---- temperature_gpu
02 October 2010 - 12:40:49
02 October 2010 - 12:40:49 Host: 192.168.1.2, Rpc Thread ID: 3796, de_11_3s_2_1336534_1286038281_1 ---- Update State
02 October 2010 - 12:40:50 TemperatureGpu ---- Computer: rishi, ClientNr: 9, GpuType: 2, NV:1, ATI: 1, Device: -1 RealDevice: -1, Temperature: 60.0
02 October 2010 - 12:40:50 TemperatureGpu ---- Computer: rishi, ClientNr: 9, GpuType: 1, NV:1, ATI: 1, Device: -1 RealDevice: -1, Temperature: 60.0
02 October 2010 - 12:40:50 rishi, Processed TThrottle: 192.168.1.3, 31417 ---- NV: 1, NA: 1, CpuMax: 40.0, GpuMax: 60.0 Gpu0: 60.0 Gpu1: 57.0 Gpu2: -1.0 Gpu3: -1.0 Gpu4: -1.0 Gpu5: -1.0
02 October 2010 - 12:40:53 rishi, Processed TThrottle: 192.168.1.3, 31417 ---- NV: 1, NA: 1, CpuMax: 40.0, GpuMax: 60.0 Gpu0: 60.0 Gpu1: 56.9 Gpu2: -1.0 Gpu3: -1.0 Gpu4: -1.0 Gpu5: -1.0
02 October 2010 - 12:40:53 TemperatureGpu ---- Computer: rishi, ClientNr: 9, GpuType: 2, NV:1, ATI: 1, Device: -1 RealDevice: -1, Temperature: 60.0
02 October 2010 - 12:40:54 TemperatureGpu ---- Computer: rishi, ClientNr: 9, GpuType: 1, NV:1, ATI: 1, Device: -1 RealDevice: -1, Temperature: 60.0
02 October 2010 - 12:40:57 TemperatureGpu ---- Computer: rishi, ClientNr: 9, GpuType: 2, NV:1, ATI: 1, Device: -1 RealDevice: -1, Temperature: 60.0
02 October 2010 - 12:40:58 TemperatureGpu ---- Computer: rishi, ClientNr: 9, GpuType: 1, NV:1, ATI: 1, Device: -1 RealDevice: -1, Temperature: 60.0
02 October 2010 - 12:40:58 rishi, Processed TThrottle: 192.168.1.3, 31417 ---- NV: 1, NA: 1, CpuMax: 40.0, GpuMax: 60.0 Gpu0: 60.0 Gpu1: 56.6 Gpu2: -1.0 Gpu3: -1.0 Gpu4: -1.0 Gpu5: -1.0
02 October 2010 - 12:41:09 rishi, Processed TThrottle: 192.168.1.3, 31417 ---- NV: 1, NA: 1, CpuMax: 40.0, GpuMax: 60.0 Gpu0: 60.0 Gpu1: 56.2 Gpu2: -1.0 Gpu3: -1.0 Gpu4: -1.0 Gpu5: -1.0
02 October 2010 - 12:41:09 TemperatureGpu ---- Computer: rishi, ClientNr: 9, GpuType: 2, NV:1, ATI: 1, Device: -1 RealDevice: -1, Temperature: 60.0
02 October 2010 - 12:41:09 TemperatureGpu ---- Computer: rishi, ClientNr: 9, GpuType: 1, NV:1, ATI: 1, Device: -1 RealDevice: -1, Temperature: 60.0
02 October 2010 - 12:41:12 rishi, Processed TThrottle: 192.168.1.3, 31417 ---- NV: 1, NA: 1, CpuMax: 40.0, GpuMax: 60.0 Gpu0: 60.0 Gpu1: 56.8 Gpu2: -1.0 Gpu3: -1.0 Gpu4: -1.0 Gpu5: -1.0
02 October 2010 - 12:41:12 TemperatureGpu ---- Computer: rishi, ClientNr: 9, GpuType: 2, NV:1, ATI: 1, Device: -1 RealDevice: -1, Temperature: 60.0
02 October 2010 - 12:41:12 TemperatureGpu ---- Computer: rishi, ClientNr: 9, GpuType: 1, NV:1, ATI: 1, Device: -1 RealDevice: -1, Temperature: 60.0
02 October 2010 - 12:41:14 Host: 192.168.1.4, Rpc Thread ID: 3964, de_11_3s_2_1334744_1286037949_1 ---- Update State
02 October 2010 - 12:41:16 TemperatureGpu ---- Computer: rishi, ClientNr: 9, GpuType: 2, NV:1, ATI: 1, Device: -1 RealDevice: -1, Temperature: 60.0
02 October 2010 - 12:41:16 TemperatureGpu ---- Computer: rishi, ClientNr: 9, GpuType: 1, NV:1, ATI: 1, Device: -1 RealDevice: -1, Temperature: 60.0
02 October 2010 - 12:41:16 rishi, Processed TThrottle: 192.168.1.3, 31417 ---- NV: 1, NA: 1, CpuMax: 40.0, GpuMax: 60.0 Gpu0: 60.0 Gpu1: 56.9 Gpu2: -1.0 Gpu3: -1.0 Gpu4: -1.0 Gpu5: -1.0
02 October 2010 - 12:41:20 TemperatureGpu ---- Computer: rishi, ClientNr: 9, GpuType: 2, NV:1, ATI: 1, Device: -1 RealDevice: -1, Temperature: 60.0
02 October 2010 - 12:41:20 TemperatureGpu ---- Computer: rishi, ClientNr: 9, GpuType: 1, NV:1, ATI: 1, Device: -1 RealDevice: -1, Temperature: 60.0
02 October 2010 - 12:41:20 rishi, Processed TThrottle: 192.168.1.3, 31417 ---- NV: 1, NA: 1, CpuMax: 40.0, GpuMax: 60.0 Gpu0: 60.0 Gpu1: 56.8 Gpu2: -1.0 Gpu3: -1.0 Gpu4: -1.0 Gpu5: -1.0
02 October 2010 - 12:41:22 Logging ---- Stop debug mode

Tried an experiment: pausing the NVidia GPU causes the BT temp to equal the ATI temp after the NVidia temp drops, so I think what's getting reported for both cards is the GpuMax.

Also noticing that the new BT versions are using MUCH more CPU time than v0.73 (about 5x on my machines) and at the same time don't seem to update as well.

Offline fred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3431
  • eFMer
    • View Profile
    • Trails
Re: Mixed NVidia and ATI GPUs
« Reply #23 on: October 04, 2010, 07:54:52 am »
Tried an experiment: pausing the NVidia GPU causes the BT temp to equal the ATI temp after the NVidia temp drops, so I think what's getting reported for both cards is the GpuMax.
Also noticing that the new BT versions are using MUCH more CPU time than v0.73 (about 5x on my machines) and at the same time don't seem to update as well.
Ok now I see what's going wrong, I hope V 0.77 will solve this.
No idea about the CPU time, check 0.77 when it comes out.

Offline Beyond

  • Active Member
  • Full Member
  • *****
  • Posts: 242
    • View Profile
Re: Mixed NVidia and ATI GPUs
« Reply #24 on: October 04, 2010, 06:37:29 pm »
Tried an experiment: pausing the NVidia GPU causes the BT temp to equal the ATI temp after the NVidia temp drops, so I think what's getting reported for both cards is the GpuMax.
Also noticing that the new BT versions are using MUCH more CPU time than v0.73 (about 5x on my machines) and at the same time don't seem to update as well.
Ok now I see what's going wrong, I hope V 0.77 will solve this.
No idea about the CPU time, check 0.77 when it comes out.
Works like a charm.  Both GPUs are reporting correct temps :)

Offline fred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3431
  • eFMer
    • View Profile
    • Trails
Re: Mixed NVidia and ATI GPUs
« Reply #25 on: October 05, 2010, 08:15:47 am »
Works like a charm.  Both GPUs are reporting correct temps :)
Finally ;D.

Offline Beyond

  • Active Member
  • Full Member
  • *****
  • Posts: 242
    • View Profile
Re: Mixed NVidia and ATI GPUs
« Reply #26 on: October 05, 2010, 05:44:56 pm »
Works like a charm.  Both GPUs are reporting correct temps :)
Finally ;D.
Took a while but was worth it.  Thanks for all the hard work!