Throttling VirtualBox BOINC Tasks

Started by tkelley, July 08, 2018, 11:18:29 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I recently installed Cosmology@Home, which spawns Linux virtual machines in Oracle VirtualBox to do the work.  They immediately began consuming 100% of the processors they were using, driving up the temperature above the set limits.  I saw reference in the development history to the addition of support for VirtualBox VMs; is there something I need to do to get TThrottle to manage BOINC tasks running in a VM?


TThrottle seems to be aware of the VMs being used by Cosmology@Home.  This line appears on the Programs tab (when "connect to BOINC client" is unchecked):

CPU: vboxwrapper_26200_windows_x86_64.exe, PID: 5560, Threads: 8

and these appear on the list on the BOINC tab: = vboxwrapper_26200_windows_x86_64
Slot = #vboxwrapper_26200_windows_x86_64.exe

Nonetheless, TThrottle seems unable to reduce the CPU usage of these processes.

The process that appears in Task Manager as the one that's eating all the CPU doesn't show up in TThrottle; it's called VBoxHeadless.exe.  Is there some way to add it to TThrottle as something that should be managed?


In the BOINC settings (Boinc Manager or BoincTasks) did you try setting Use at most xx % of CPU time.
That should limit the amount of time the CPU is allowed to run on a task.

With Throttle it's not always possible as in this case.


Great idea!  That worked well.  Can't believe I didn't think of it.  Thank you!


you can also "cheat" and set a lower Tjunction temp.

My Kryptos@home VM were running at 95C without throttle kicking in.
Tjunction was at 100C.
I set it a 85C and voila :D
Tthrottle is working now :D