Suddenly lost android phones from list

Started by hucker, August 26, 2022, 06:01:41 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I use Boinctasks for 7 windows computers and 3 Android phones, it runs on my main windows computer.  2 days ago all three phones said not connected and have done ever since.  They are connected to my wireless just fine, and have not changed IP address.  They continue to run Boinc and download and upload tasks ok.  I can ping them all from the main windows PC.  I had made no changes to the phones.  I tried restarting all the phones and the PC, but I still cannot connect with Boinctasks.  I've verified they have remote control enabled with the correct password in their Boinc clients (official version 7.18.1).  Any ideas?


Is there anything in the BOINC messages on the Android phones that shows the attempt to connect, like refused, not allowed.
You checked if the IP addresses are indeed correct.
Any system updates on the Android phones?
Did you install a firewall on the phones?


The client messages list on the phones just shows the usual project communications.  The gui message list is empty.  Can I turn on some kind of debugging logging?

Is there a log in Boinctasks on Windows of connection attempts?

I'm not aware of any updates, I know Google tends to do that itself, but there's usually a notice.  And I don't think they updated all three at once since they're Android 4, 7, and 9.  I doubt they even update 4 any more.

Only the Android 4 phone has a firewall, but it's switched off.


There should be lines like this.

15         8/28/2022 10:50:36 AM   Config: GUI RPC allowed from any host   
16         8/28/2022 10:50:36 AM   Config: GUI RPCs allowed from:   

Or a blocked one

278         8/28/2022 10:50:38 AM   GUI RPC request from non-allowed address   

BoincTasks can log connection in the Logging window.
Check Enable debug logging
Click on Debug setup
Check Connecting
Close and restart BoincTasks.


Boinc on my androids doesn't look like that.  I see things like:

28 Aug 2022 21:16:42
Project requested delay of 11 seconds

And many more three line paragraphs, all project related, nothing to do with Boinctasks connecting.

In Boinctasks, I assume you mean the "show" menu, followed by "log"?  I can't see any debug logging to enable there, although the dialog box is a bit odd, there are two buttons at the bottom which are blank, one seems to clear the log and one closes the window.


I decided to get violent.  I uninstalled Boinc from a phone, deleted it from the Boinctasks list, then started from scratch.  I can see that phone now.  Who knows what happened.



Well that didn't go as planned.

Yesterday I reinstalled Android 9 phone's Boinc.  Success.
Reinstalled Android 7 phone's Boinc.  Success, but the Android 9 failed again.  Decided to leave it till today.
Reinstalled Android 4 phone's Boinc.  I got very angry with the rubbish phone I'd bought from China for £20 5 years ago (and got a full refund as it's a fake, was advertised as Android 6).  After failing to download Boinc through a browser and also finding the bluetooth receiver was busted, I put Boinc on an SD card and shoved that in it.  But although the phone is on the internet and I can browse websites, Boinc insists there's no internet connection.  The OS says Boinc has full network permission.  I threw it in the recycling box.  It's only a 2 core CPU anyway.
Today I tried the Android 9 again, and it worked, allowed me to set up the projects, then promptly disappeared.

Do you have any idea how to do some tracing on this?


Quote from: hucker on August 29, 2022, 08:04:27 PM
Do you have any idea how to do some tracing on this?
You should be able to access the BOINC client log if you connect the phono to your computer.
Somewhere in this folder This PC\yourphone\Internal shared storage\Android\data


Something weird going on here, I can access the folder tree, but everything appears empty, even though I can tell form the computer the phone has 6GB of files, I cannot see them!  I'll ask in an Android help forum.


Ok, fixed that, it was set to USB debug mode as I'd been adjusting the OS earlier.

So now i can get into android/data, and in there is a list of folders and only one looks like boinc, it's "edu.berkeley.boinc", but it only contains one empty folder called "files".  Boinc is running, i can see it on the phone running tasks.

That same folder also shows as empty using the Android file manager.


Quote from: hucker on August 30, 2022, 10:15:39 PM
That same folder also shows as empty using the Android file manager.
The logging in the BOINC Manager should give you the data directory.
Asking on the BOINC Android forum could help.