Author Topic: Remote PCs 'Not connected'  (Read 4586 times)

0 Members and 1 Guest are viewing this topic.

Offline yoro42

  • Jr. Member
  • **
  • Posts: 28
    • View Profile
Remote PCs 'Not connected'
« on: September 09, 2011, 05:14:13 pm »
I've installed BT and it works great on my localhost (i7 6 core 12 logical processors 24 GB memory, W7).  My network is connected to a PK5000 modem from QWEST.

localhost W7  -- wireless >                             |=> internet      
                                        < wireless --   PK5000   ---ethernet ----   desktop XP
Laptop W7    -- wireless >               

I've installed BT & TThrottle on all three PCs.  I've installed remote_hosts.cfg and gui_rpc_auth.cfg  in both BOINC folders (in Program Files and Program Files (x86)) on both the Laptop and the XP system.

Where do I go from here to resolve this problem?

Thanks,



Offline Pepo

  • Tester
  • Hero Member
  • *****
  • Posts: 875
    • View Profile
Re: Remote PCs 'Not connected'
« Reply #1 on: September 09, 2011, 05:29:56 pm »
Where do I go from here to resolve this problem?
And, what's the problem? ;)
(I suppose your i7 machine's BT can not see the other two machines. Right?)

I've installed BT & TThrottle on all three PCs.  I've installed remote_hosts.cfg and gui_rpc_auth.cfg  in both BOINC folders (in Program Files and Program Files (x86)) on both the Laptop and the XP system.
No need to place them there, they can stay in BOINC data folders.

All remote clients' remote_hosts.cfg should contain the IP address (or FQDN or NETBIOS name) of the machine running BT (i.e. the i7).
You also have to enter the "passwords" from the remote machines' gui_rpc_auth.cfg files into BT's Computers tab, Password column.
Peter

Offline yoro42

  • Jr. Member
  • **
  • Posts: 28
    • View Profile
Re: Remote PCs 'Not connected'
« Reply #2 on: September 09, 2011, 06:08:08 pm »
I have the IP of the i7 system in remote_hosts.cfg and the password in gui_rpc_auth.cfg on both remote systems. Is there a position format for either cfg file?

Offline Pepo

  • Tester
  • Hero Member
  • *****
  • Posts: 875
    • View Profile
Re: Remote PCs 'Not connected'
« Reply #3 on: September 09, 2011, 07:08:00 pm »
I have the IP of the i7 system in  and the password in gui_rpc_auth.cfg on both remote systems. Is there a position format for either cfg file?
A position format?

remote_hosts.cfg can be as simple as e.g. just one line with
Code: [Select]
192.168.2.133 (assuming 192.168.2.133 is your i7 machine's IP). This IP is to be placed in each remote client's remote_hosts.cfg, in its BOINC data folder.

gui_rpc_auth.cfg may contains some text like "MyPassword" or "L!ttleS@sIe", the BOINC-generated are without a trailing newline/linefeed/carriagereturn. Each client has its own gui_rpc_auth.cfg file, in its BOINC data folder. It doesn't matter, whether all passwords are same or some do differ. Just the BoincTasks should know all of them.
Peter

Offline yoro42

  • Jr. Member
  • **
  • Posts: 28
    • View Profile
Re: Remote PCs 'Not connected'
« Reply #4 on: September 09, 2011, 07:28:27 pm »
The IPs and passwords are /have been entered correctly. Still 'Not connected'.

Offline yoro42

  • Jr. Member
  • **
  • Posts: 28
    • View Profile
Re: Remote PCs 'Not connected'
« Reply #5 on: September 10, 2011, 04:22:53 pm »
Any ideas on how to fix this? Please refer to 'above' for additional info?

10 September 2011 - 06:05:01 BoincTasks version: 1.16
10 September 2011 - 06:05:02 Language ---- User: 1033 (ENU), System: 1033 (ENU), Selected: 0 () Used: 1033 (ENU)
10 September 2011 - 06:05:02 Maximum number of computers: Unlimited
10 September 2011 - 06:05:02 Computers ---- Rory , localhost
10 September 2011 - 06:05:02 Computers ---- Matty , 192.168.0.3
10 September 2011 - 06:05:02 Computers ---- Jamal , 192.186.0.2
10 September 2011 - 06:05:02 Connect ---- Connected to: Host: localhost, Rory, Port: 31416, BOINC Version: 6.12.33
10 September 2011 - 09:05:23 Logging ---- Start debug mode
10 September 2011 - 09:05:23 Logging ---- fileonly
10 September 2011 - 09:05:23
10 September 2011 - 09:05:24 Connect, init ---- Host: 192.186.0.2, Jamal,Port: 31416, connection error
10 September 2011 - 09:05:24 Connect, init ---- Host: 192.168.0.3, Matty,Port: 31416, connection error

10 September 2011 - 09:05:30 Logging ---- Stop debug mode

Thank you,


Offline TeeVeeEss

  • Jr. Member
  • **
  • Posts: 17
    • View Profile
Re: Remote PCs 'Not connected'
« Reply #6 on: September 10, 2011, 07:56:34 pm »
Have you checked firewall-setting on all systems?
By the way: BT is only needed at the host on which you will control the other two.
« Last Edit: September 10, 2011, 07:59:41 pm by TeeVeeEss »

Offline yoro42

  • Jr. Member
  • **
  • Posts: 28
    • View Profile
Re: Remote PCs 'Not connected'
« Reply #7 on: September 11, 2011, 04:24:57 pm »
Firewall settings look good on all three systems. I've uninstalled BOINCTasks from all systems and will install it again on the localhost system only. I'll post an update as soon as I have results.

Offline yoro42

  • Jr. Member
  • **
  • Posts: 28
    • View Profile
Re: Remote PCs 'Not connected'
« Reply #8 on: September 11, 2011, 07:57:33 pm »
Could not get BOINCtasks to work again after reinstalling (boinctask64 kept dumping).  Uninstalled 1.16 and installed BT 1.20 which works fine for the localhost. However, my original problem remains:

11 September 2011 - 12:26:37 Computers ---- PC1 , localhost
11 September 2011 - 12:26:37 Computers ---- PC2 , 192.168.0.2
11 September 2011 - 12:26:37 Computers ---- PC3 , 192.168.0.3
11 September 2011 - 12:26:37 Connect ---- Connected to: Host: localhost, PC1, Port: 31416, BOINC Version: 6.12.33
11 September 2011 - 12:26:58 Connect, init ---- Host: 192.168.0.2, PC2,Port: 31416, connection error
11 September 2011 - 12:26:58 Connect, init ---- Host: 192.168.0.3, PC3,Port: 31416, connection error



Offline Pepo

  • Tester
  • Hero Member
  • *****
  • Posts: 875
    • View Profile
Re: Remote PCs 'Not connected'
« Reply #9 on: September 12, 2011, 09:20:54 am »
Are you able to connect your i7 hosts' BOINC manager to the remote clients (192.168.0.2 + 192.168.0.3)?
Peter

Offline yoro42

  • Jr. Member
  • **
  • Posts: 28
    • View Profile
Re: Remote PCs 'Not connected'
« Reply #10 on: September 12, 2011, 12:48:41 pm »
Good morning.

No. When I select either PC (W7 lap top or XP Desktop) ti goes to a "Connecting to PC Name then Disconnected & starts over. The same connecting  -disconnecting process occurs if I use IP address instead of PCname.

I can connect via 'Remote Desktop Connection'.

Offline TeeVeeEss

  • Jr. Member
  • **
  • Posts: 17
    • View Profile
Re: Remote PCs 'Not connected'
« Reply #11 on: September 12, 2011, 02:38:03 pm »
Just to be sure it's not a firewall-problem: have you tried to disable firewall on all 3 rigs and then to connect through BT or BOINC-manager?

Offline yoro42

  • Jr. Member
  • **
  • Posts: 28
    • View Profile
Re: Remote PCs 'Not connected'
« Reply #12 on: September 12, 2011, 05:26:12 pm »
Unable to  connect via BOINC Manager after turning Firewall off on all three systems. Looks like the problem is with BOINC instead of BoincTasks. I can PathPing in one hop to any of the other two systems.

Offline Pepo

  • Tester
  • Hero Member
  • *****
  • Posts: 875
    • View Profile
Re: Remote PCs 'Not connected'
« Reply #13 on: September 13, 2011, 12:27:25 pm »
If BOINC client does not recognize a connecting machine (e.g. not listed in remote_hosts.cfg or the IPs do not match), a corresponding message gets logged in stdoutdae.txt (unfortunately I do not remember its exact wording) - do you see anything there at the moments you try to connect? If not, then the packets possibly do not even get through to the client.

Do you see Rory (PC1) listed below the "Config: GUI RPC allowed from:" line in both Jamal's (PC2) and Matty's (PC3) stdoutdae.txt?

If you download and start a PuTTY terminal on Rory, enter Host Name = localhost, Connection type = telnet, Port = 31416, Open this connection and press "Enter" key in the terminal window, you should get at least
Code: [Select]
<boinc_gui_rpc_reply>
                     <unauthorized/>
                                    </boinc_gui_rpc_reply>

If you try the same with remote hosts, do you get anything (similar)?
Peter

Offline wicked

  • Active Member
  • Jr. Member
  • *****
  • Posts: 39
    • View Profile
Re: Remote PCs 'Not connected'
« Reply #14 on: October 03, 2011, 02:59:49 pm »
Unable to  connect via BOINC Manager after turning Firewall off on all three systems. Looks like the problem is with BOINC instead of BoincTasks. I can PathPing in one hop to any of the other two systems.

This sounds like there is a firewall or port restrictions on the PK5000 modem. Have you verified that part?