Can't connect to BOINC client

Started by Shin, March 19, 2020, 11:50:26 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I can't seem to find or add my computer running BOINC using the "Find computer" or "Add computer" menus. I used the machine IP, password in gui_rpc_auth.cfg, and port 31416. But no luck, I've tried adding a TCP exception in the firewall but that doesn't seem to work either.

Any idea around this? Not sure if it's just me forgetting something.  ::)


Windows or Linux client?

If Linux then at /etc/boinc-client you need to edit the file remote_hosts.cfg and add the name of the boinctasks system or its IP address.  This is not needed for windows.

If client is in windows make sure there is only one client running and that the manager is not running.  Use tasks manager to verify.  Make sure that each system can "ping" the other using system names else network problem.

From the system running the client, from an admin command prompt do the following:
c:\Program Files\boinc>boinccmd --get_host_info

do the same thing from system running boinctasks. I assume it is also running boinc (but not boincmgr)
c:\Program Files\boinc>boinccmd --host YOUR_REMOTE_SYSTEM --get_host_info

Installing boinctasks under windows should automatically ask to allow access through the firewall.

If each system can ping each other then try a telnet connection from the boinctasks system to the client


Pressing CTRL-C should generate an error message such as "<boinc_gui_rpc_reply>" plus other stuff.   If you do not see that message suspect firewall or network problem.  Use CTRL-] then "quit" to exit telnet.



I tried the host-info command and got the IP, but even that doesn't work when trying to connect. When I do the host-info to a remote machine that doesn't output anything.
I can ping both IPs perfectly with instant responses. Both machines are Windows

And I have checked that only one BOINC client is running.


Put the following into the cc_config.xml file at \programdata\boinc under "options"


suggest this:

double check your password file for white space or unprintable character.   If you delete the gui_rpc_auth.cfg file it is automatically re-created with a 32 char password when boinc starts up.  Best is to use notepad and delete the line and save an empty file.  Its length should be exactly "0" unless you want a password


I am having the same issue.  this is a linux client, and I am running BoincTasksJS under Linux.  I have 5 computers in my network, 2 are Windows, 3 are Linux.

One Linux Machine is invisible to Boinctasks, However I can use the Boinc manager to remotely get access to the  remote Boinc manager.

I can ping the node too.


Quote from: coolvan on November 17, 2022, 01:06:22 AM
One Linux Machine is invisible to Boinctasks, However I can use the Boinc manager to remotely get access to the  remote Boinc manager.
Is there an entry in the BOINC log on the machine you can't connect to?
Something is refusing the connection.
The only thing I can think of is a password problem.
You can connect to the BOINC client with BOINC manager on the same computer you use BoincTasks on.